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1. Introduction to Minitab 21 

Welcome to Minitab 21! Our latest release offers many new features, including: 
 

• Automated Machine Learning for binary and continuous responses available in the 
Predictive Analytics Module, an optional add-on. 

 
• The Healthcare Module, an optional add-on, is now available in French, German, 

Japanese, Korean, Portuguese, Simplified Chinese, and Spanish. 
 

• Cox Regression techniques available in the Reliability/Survival menu. 
 

• Graph editing options available for graphs in Graph Builder. 
 

• Interactive Probability Plot available in Graph Builder. 
 
In addition to these new Desktop features, Minitab 21 also offers a web version of Minitab. The 
web version of Minitab allows you to open projects from Microsoft OneDrive®, Google Drive™, 
or a local file. The web version offers many of the same features as the Desktop version to allow 
you to access Minitab anytime, anywhere. 
 
Visit www.minitab.com for more information. 
 

2. New Features in Minitab 21.1.1 

• Supply Chain Module – This optional add-on module allows users to shift focus to 
improving key performance indicators (KPIs) like cycle time, inventory, delivery, quality, 
profitability, and costs rather than worrying about which analysis to use. 

• Customer Contact Center Module – This optional add-on module allows users to shift 
focus to improving key performance indicators (KPIs) like service levels, utilization and 
cost, ticket volume, time management, ticket resolutions, and customer satisfaction 
rather than worrying about which analysis to use. 

3. New Features in Minitab 21.2 

• There are three new features in the Time Series Menu 
o Box-Cox Transformation 
o Augmented Dickey-Fuller Test 
o Forecast with Best ARIMA Model 

• The following interactive graphs are now available in Graph Builder. 
o Line Plot  
o Pie Chart 
o Stacked Area Graph 

http://www.minitab.com/
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• Publish to Model Ops – From Minitab Statistical Software, directly publish a supported 
model to Model Ops by clicking the Publish to Model Ops button. 

4. New Features in Minitab 21.3  

• The following interactive graphs are now available in Graph Builder. 
o Matrix Plot 
o Interval Plot 

• Distribution Fit can now be added to Histogram in Graph Builder. 
• Measurement System Analysis Module - This optional add-on module provides guided 

data analysis to solve all the most common MSA challenges.  Get right to problem 
solving without worrying about which analysis to use. 

• Sample Size Module - This optional add-on module help you to estimate the required 
sample size to assure you will have enough power to meet your needs. 

• Insurance Module - This optional add-on module provides guided data analysis to solve 
common insurance industry challenges. Shift your focus to improving key performance 
indicators (KPIs) like Time to Settle a Claim, Revenue per Policy Holder, and Claims 
Ratios without worrying about which analysis to use. 

5. New Features in Minitab 21.4 

• The following additional graph editing options are now available in Graph Builder. 
o Regression Fit can be added to Scatterplot and Matrix Plot. 
o Percentile Lines can be added to Probability Plot. 
o The Probability Plot Y-scale can be adjusted to Probability or Score, in addition 

to Percent.  
o The scale on a Histogram can be adjusted to specify an interval type and an 

interval definition. 
• Additional analyses in Basic Statistics, Time Series, and Regression can be updated in the 

output pane when data changes. 
• The Predictive Analytics Module now includes MARS® Regression. 

6. Problems Resolved in Minitab 21.2 

The following issues are resolved in Minitab 21.2. 

Desktop Application 

In a concurrent License Portal subscription, closing the Minitab 20 desktop app without explicitly 
clicking "Sign Out", does not immediately release the seat. (183723) 

When you update a graph that has a different decimal separator than you are currently using, 
the update sometimes fails. (183729) 

Minitab crashes when a column with missing values is used with the Assistant Menu Graphical 
Analysis Main Effects Screener. (185406) 
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In the graph Layout Tool window, the graph names listed in the list box are not synchronized 
with the graph names in the output pane’s Navigator. (179709)  

Resaving some large projects (for example, 1GB) can be problematic. (184713)  

In the Cox Regression dialog box, options in the Censor drop-down menu are omitted if the 
Censor column contains missing values. (185044)  

When you set Pareto and Half normal preferences under File Options, then create a General Full 
Factorial Design, an unexpected error occurs. (185273)  

Web Application 

Adding a Dendrogram to a report causes Minitab to crash. (174330) 

The “Graph Options” menu is missing for Line Plot. (185042)   

The Analyze Factorial dialog box does not allow a center-point term when the design has center 
points. (184695)   

When you store standardized results in a named column, an error occurs. (184458)   

When you assign a formula from the right-click menu with a column name that contains “let”, 
an error occurs. (183540)   

Desktop and Web Applications 

A categorical predictor that is not used to build the optimal tree in CART may be incorrectly 
listed as the most important variable in Relative Variance Importance Plot. (184330)   

An exception error occurs with Matrix multiplication in the Response Optimizer. (184721) 
A Run-Time Exception for Double Exponential Smoothing occurs with large amounts of data. 
(178441)    

If you run CART classification with a large amount of data, Minitab might crash. (184443) 
In the Terms sub-dialog box of Analyze Mixture Design, the Chinese translations for “linear” and 
“quadratic” are reversed for the mixture amount term order. (180734)   

In the Graph Builder, Bar Chart shows “Mean” for the function, but uses “Count” in the graph 
that is generated. (172218)  

The ability to create extreme vertices design (EVDESIGN) depends on the entry order of the 
components. (185225)   

7. Problems Resolved in Minitab 21.3  

The following issues are resolved in Minitab 21.3. 
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Desktop Application 
 
Users are unable to sign in to the Desktop application based on specific security policies set by 
their company. (PR184019)  
 
The Print Data Pane dialog is missing the OK button in German. (PR183949)  
 
Duplicating a Scatterplot with an overlaid model and scale transformation produces an error. 
(PR176146)  
 
Editing a Line Plot to show percent values then duplicating the graph creates a graph that does 
not match the original. (PR174159)  
 
A macro that includes a subroutine which includes the PPLOT command causes the application 
to crash. (PR182245)  
 
A macro that includes the command MTITLE causes performance issues on later runs. 
(PR185457)  
 
Copying and pasting data from Excel into a new Minitab worksheet causes an assertion failure. 
(PR185388)  
 
Selecting the Cancel button in the Graph Builder dialog can sometimes cause the application to 
crash in memory intensive use cases. (PR185031) 
  
Web Application 
 
The application crashes when attempting to edit a Matrix Plot that was created via Graph 
Builder. (PR185721)  
 
The application crashes when a Dotplot is added to a Report. (187415)  
 
Some graph types that are set to auto update produce an error when an edit is applied to the 
graph twice. (192654)  
 
Desktop and Web Application 
 
Individual value plots that display many outputs do not always display properly. (PR183109)  
 
In 2-Sample Poisson, Sample Rate values are incorrect in the output. (PR185333)  
 
In some cases, symbols with a Z value greater than ~200 do not appear on Contour Plots. 
(PR185614)  
 
A Minitab Online project that is opened in the desktop application displays copy and paste 
problems when the copied and pasted columns are hidden. (PR185697)  
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8. Problems Resolved in Minitab 21.3.1  

Desktop Application  
 
Dynamic Data Exchange (DDE) links within a project result in corrupted projects. (185924)  
  
Opening a Minitab project file within Minitab Engage® or Minitab Workspace® causes Minitab® 
Statistical Software to crash. (185903)  
  
Desktop and Web Application  
 
Predictions from CART®, TreeNet®, Random Forests®, and Discover Best Model are incorrect when 
categorical predictors with single quotes in the levels are included in the model. (185948)  
 
 

9. Problems Resolved in Minitab 21.4 

Desktop Application  
 
Minitab may crash when you try to conduct a 1-Sample t or 1-Sample Z on a column that is 
empty. (185035) 
 
Minitab may crash when you undo a graph edit that caused a warning or error to appear. 
(196392) 

The desktop application displays the incorrect product version under Help > About Minitab in all 
non-English language versions. (186026) 

Web Application 
 
Using the browser back button may cause the web application to lose its current session. 
(194908) 
 
You cannot see the Help, OK, or Cancel buttons in the graph gallery dialogs unless you scroll. 
(196686) 
 
The caution message that is displayed when you cut, delete, or clear data is unclear and not fully 
translated. (198730) 
 
Desktop and Web Application 
 
The Augmented Dickey-Fuller Test table is not properly formatted when sent to a report. 
(202709) 
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Probability Plot does not display error message when the chosen distribution is incompatible 
with Scale type. (199707, 199712) 
 
In Generalized Linear Model, the hierarchy check is incomplete when an interaction exists 
between two nested terms. (178236) 
 
When you edit an analysis with multiple graphs, the vertical scroll position of the Options pane 
and the expand/collapse state of the accordion controls reset when you select a different graph. 
(184583) 
 
The Graph Options Pane may not reflect the current state of the graph with Undo/Redo. 
(197667) 
 
The test results for control charts are not included when sent to a report. (185189) 
 
Probability Plot does not display warnings when a distribution cannot be fit. (195154) 
 
The Graph Builder Histogram shows an incorrect tooltip in grouped cases. (196312)  
 
The Graph Builder Probability Plot tooltip is incorrect when a custom Y axis label is used. 
(196540) 
 
When you save a project that includes a Taguchi design with missing data in the factor column, 
you cannot open the project later. (185777) 
 
The Distribution Parameters table for the Graph Builder Histogram does not honor styling 
Options that you set in the project. (197260) 
 
An error may occur when you use Tables > Descriptive Statistics with data that includes missing 
values. (200524) 
 
The Parallel Coordinates Plot crashes when all missing columns are used. (201863) 
 
An error is produced when you update an Individuals Chart with time scale reference lines. 
(186009) 
 
Minitab crashes when you paste formatted cells and additional columns in a new project. 
(186094) 
 
A Minitab project file created in version 21.3.1 cannot be opened in version 21.1.1. (186092) 
 
Minitab may crash when saving a project that includes a Z-MR chart. (205079) 
 
Minitab may crash if a hidden column is deleted, and then the Undo action is performed. 
(205579) 
 
The accuracy measures (MAPE, MAD, MSD) for Time Series models in the Portuguese version of 
Minitab are inconsistent between the application and Help content. (182749) 
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10. Known Problems and Workarounds 

Item 1 
When you create a histogram, probability plot, or empirical CDF from the Graph menu and 
specify a distribution, Minitab may display an incorrect error, even if Data Options was used to 
exclude the portion of data that causes the error. (143049)   
 
WORKAROUND: Before you create the graph, use Data > Subset Worksheet to create a new 
worksheet that excludes the offending values.  
 
WORKAROUND: Create the graph using the normal distribution and then double-click the 
distribution displayed on the graph to specify a different distribution.  
 
Item 2 
If you use stepwise regression to analyze a mixture design with process variables, and one or 
more process variables are dropped by the stepwise procedure, the dropped process variables 
appear in the output with coefficients of zero. As a result, graphs of the model, including 
contour, surface, and optimization plots, show that the dropped process variables have no 
effect on the response, even though these variables were not included in the model. (9047)  
 
WORKAROUND: Run the analysis again without the dropped process variables. 
 
Item 3 
Creating a Minitab graph can crash Minitab if you have an outdated or incompatible video card 
driver. (6501) 
 
WORKAROUND: Upgrading to the latest video driver for your particular video card may fix this 
problem. 
 
WORKAROUND: Choose File > Options > Graphics > Other Graphics Options and check Disable 
hardware acceleration. 
 
Item 4 
In rare circumstances, Minitab project files (*.MPJ, *.MPX) can become corrupt, and Minitab will 
be unable to open these files. (124217, 7128)  
 
WORKAROUND: Locate the project's backup file (*.BAK file with the same name as the corrupt 
project located in the same folder). Launch a new instance of Minitab, then drag-and-drop the 
*.BAK file into Minitab. In most cases, this will recover the project. If the project recovers 
successfully, immediately save the project using a new file name. If this backup fails, contact 
Minitab Technical Support (http://www.minitab.com/contact-us).  
 
Item 5 
In rare cases, customers have received the following error message when opening a project file: 
“An error has occurred while reading project file: MYFILENAME.MPX.” (8548, 8610, 8908) 
 

http://www.minitab.com/contact-us
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WORKAROUND: Locate the project's backup file (*.BAK file with the same name as the corrupt 
project located in the same folder). Launch a new instance of Minitab, then drag-and-drop the 
*.BAK file into Minitab. In most cases, this will recover the project. If the project recovers 
successfully, immediately save the project with a new file name. If this backup fails, contact 
Minitab Technical Support (http://www.minitab.com/contact-us).  
 
Item 6 
Graphs based on models with weights do not show as out-of-date if you modify the data in the 
weight column. (172888) 
 
Item 7 
When you open a text file (*.TXT), the Preview window may appear empty if the first 100 or 
more rows are empty or when you type a value of 100 or greater in First row to import. 
(175474) 
 
Item 8 
The Cancel button in the standard toolbar is not responsive with a slow running macro. (179705) 
 
WORKAROUND: Use the keyboard shortcut CTRL+Break. 
 
Item 9 
When you open a project in English that was created in a non-English language, the dialog boxes 
that you used will still appear in the non-English language. (179748) 
 
Item 10 
The legend for the Parallel Coordinates Plot may be incomplete until the graph is resized. 
(182566) 
 
Item 11 
If you send a large amount of output, such as a CART® Classification tree with many nodes, to 
Minitab Workspace™ or Companion by Minitab, these applications may crash. (182523) 
 
Item 12 
Intermittently, Send to Microsoft Word® does not send all output from Minitab to Microsoft 
Word®. (179956) 
 
Item 13 
In some cases, printing a Parallel Coordinates Plot from the command level context menu in the 
Output Pane may not work and may prevent printing at the command level for other 
commands. (182664) 
 
WORKAROUND: Print a Parallel Coordinates Plot from the graph context menu or copy or send 
to Microsoft Word®/PowerPoint® and print from those applications. 
 
Item 14 
If the internet is disconnected when you work with a project in an online repository (Microsoft 
OneDrive® or Google Drive™), the project in the repository may remain locked. (182648) 
 

http://www.minitab.com/contact-us
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WORKAROUND: In the online repository, check in the project or discard the check out. 
 
Item 15 
To share Google Drive™ projects in Microsoft Edge®, change Tracking Prevention to Basic in the 
Microsoft Edge® privacy settings. (182646) 
 
Item 16 
To open worksheets (mtw and mwx) in the web version of Minitab when using Microsoft 
OneDrive®, you must use File > Open > Worksheet. You cannot open worksheets directly from 
Microsoft OneDrive®. (182652) 
 
Item 17 
In the web version of Minitab, you cannot copy CART® tree diagram items from the context 
menus when you use Safari ®. (182654) 
 
WORKAROUND: Select the tree diagram and use Command+C.  
 
Item 18 
When you share Minitab projects through email, the recipient can only download the project 
and not open it directly in the web version of Minitab. (182658) 
 
WORKAROUND: Navigate to the Shared directory in Microsoft OneDrive®, click the ellipsis and 
then select Preview > Open > Open with Minitab. 
 
Item 19 
When you create a project in Minitab 21 that contains a CART® model that includes the Relative 
Variable Importance Chart, you will not see any of the CART® output associated with that model 
when you open the project in Minitab 19.2020.1, 20.1, 20.1.2, or 20.1.3. (183463) 
 
Item 20 
Binned Scatterplots in the Graph Builder do not display on Virtual Machines. (183779) 
 
WORKAROUND: In File > Options > Graphics > Other Graphics Options, check Disable hardware 
acceleration. 
 
Item 21 
Google Sheets™ cannot be opened in the Minitab Desktop app. (183961) 
 
Item 22 
Users who are licensed through the Minitab License Portal using Single Sign-on and Multi-Factor 
Authentication cannot sign into the Desktop app on Microsoft Windows 8.1. (184362) 
 
WORKAROUND: Use the web app or upgrade to Microsoft Windows 10. 
 
Item 23 
Opening a project from a repository (Microsoft OneDrive® and Google Drive™) will cause the 
Desktop app to crash on Microsoft Windows 8.1. (184364) 
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WORKAROUND: Use the web app or upgrade to Microsoft Windows 10. 
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